
  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.utdailybeacon.com/content/tncms/live/" />
<meta name="keywords" content="entertainment, city_news" />
<meta name="news_keywords" content="entertainment, city_news" />
<meta name="description" content="After what felt like a months-long standoff between the two companies, we finally have definitive details on the release date and prices of the next-gen consoles." />
<meta name="author" content="Seth Chapman, Staff Writer" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.utdailybeacon.com/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=1120%2C630" />
<meta property="og:image:width" content="1120" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Xbox Series X and PlayStation 5 release date, price unveiled, next generation of consoles on the horizon" />
<meta property="og:description" content="After what felt like a months-long standoff between the two companies, we finally have definitive details on the release date and prices of the next-gen consoles." />
<meta property="og:site_name" content="The Daily Beacon" />
<meta property="og:section" content="Entertainment" />
<meta property="fb:app_id" content="1569383999993988" />
<meta property="article:publisher" content="https://www.facebook.com/pages/The-Daily-Beacon/133245626686451" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@UTKDailyBeacon" />
<meta name="twitter:image:alt" content="Xbox Series X and S" />
<meta property="fb:pages" content="133245626686451" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.5cfe8d2b6e902b79c4710d15b491c631.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.c9c732b035a293475d6df8121863ef5a.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/live/global/resources/styles/site.css?_dc=1455225087"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/owl.carousel.d631cca58a0d014854c4a6c1815f1da3.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<style>/*<![CDATA[*/ #user-controls-1211721 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1211721 .tn-user-screenname, #user-controls-1211721 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1211721 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1211721 .dropdown-signup { font-size: 12px; } #user-controls-1211721 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1211721 .large-user-avatar { margin-right: 10px; } #user-controls-1211721 .large-user-controls { font-size: 12px; } #user-controls-1211721 .logout-btn { cursor: pointer; } #user-controls-1211721 .login-btn { color: #fff!important; } #block-1211706 .search-spinner { position: absolute; } #block-1211706 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1211706 { margin-bottom: 0; } #site-search-1211706 .site-search-form { padding: 0; } #site-search-1211706 #site-search-1211706-btn { outline: none; } #site-search-1211706 #site-search-1211706-term { border: 0; box-shadow: none; } #site-search-1211706 .site-search-form { box-shadow: none; } #tncms-block-1211697 .tnt-prop-img { max-width: 417px; } #user-controls-1211720 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1211720 .tn-user-screenname, #user-controls-1211720 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1211720 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1211720 .dropdown-signup { font-size: 12px; } #user-controls-1211720 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1211720 .large-user-avatar { margin-right: 10px; } #user-controls-1211720 .large-user-controls { font-size: 12px; } #user-controls-1211720 .logout-btn { cursor: pointer; } #user-controls-1211720 .user-welcome { color: #98c3c8; } #user-controls-1211720 .login-btn { color: #fff!important; } .follow-links-1211708 li { margin-right: 1px; padding: 0; } .follow-links-1211708 li a, .follow-links-1211708 li a:focus, .follow-links-1211708 li a:active { ; color: #FFFFFF!important; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-1211708 li a:hover { text-decoration: none; opacity: 1; } .follow-links-1211708 li a.fb:hover { color: #3A59A5; } .follow-links-1211708 li a.tw:hover { color: #46C8F9; } .follow-links-1211708 li a.yt:hover { color: #CE2B29; } .follow-links-1211708 li a.is:hover { color: #D4C4A2; } #block-1231239 .search-spinner { position: absolute; } #block-1231239 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1231239-dropdown .dropdown-menu { padding: 15px; width: 400px; font-weight: normal; } @media screen and (max-width: 991px) { #site-search-1231239-dropdown .dropdown-toggle { display: none; } #main-navigation .navbar-left { clear: both; } #site-search-1231239-dropdown .pull-right { float: none!important; } #site-search-1231239-dropdown .dropdown-menu { display: block; position: static; float: none; width: auto; margin-top: 0; background-color: transparent; border: 0; box-shadow: none; border-radius: 0; border-bottom: 1px solid rgba(0,0,0,0.1); } } #block-1211677 .poll-panel { background-color: #FFF; border-color: rgba(0,0,0,.08); } #block-1212076 .card.showcase { border: 0; padding: 0; margin: 0; } #block-1212076 .card-panel { background-color: #fff; border-color: rgba(0,0,0,.08); width: 100%; } #block-1212076 .card .card-image-full { width: 100%; } #block-1212076 #card-showcase-e9efa63c-fe03-11ea-be0c-63f2aaab7b07 .showcase-box { width: 24% } #block-1212076 #card-showcase-d2250de4-fd13-11ea-b9c7-8b2d5e61e73f .showcase-box { width: 24% } #block-1212076 #card-showcase-db8a89b8-fcf5-11ea-9225-478d27f13c4a .showcase-box { width: 24% } #block-1211652 .card.summary { border: 0; padding: 0; margin: 0; } #block-1211652 .card-panel { background-color:#fff; border-color: rgba(0,0,0,.08); } #tncms-block-1211699 .tnt-prop-img { max-width: 596px; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"banded","style":"default","path":"\/city_news\/entertainment","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"Seth Chapman, Staff Writer","id":"66f6f9d2-fe95-11ea-b6aa-c765948b3777","app":"editorial"},"vendor":{"outbrain":"disabled","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":219},"client":{"is_bot":"yes","is_gdpr":"no"},"google":{"ua":"UA-65761023-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/ads/impressions.js?_dc=1600983337"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/ads/traffic.js?_dc=1600922128"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/ads/settings.js?_dc=1569613921"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/ads/fixed-big-ad-middle-asset/1.js?_dc=1600934470"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/search/resources/scripts/tnt.followed.notifications.6600e99595fd219e961e9882c796e61c.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.facebook.comments.89e3602c68154764e889947868c957c9.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/ads/fixed-big-ad-top/1.js?_dc=1599055264"></script>
<script>/*<![CDATA[*/ window.poll_config || (window.poll_config = []); window.poll_config.push({"id":"fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08-1211677","asset_id":"fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08","title":"Do you wear your mask when you are walking around outdoors on campus?","url":"\/do-you-wear-your-mask-when-you-are-walking-around-outdoors-on-campus\/poll_fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08.html","results":"https:\/\/www.utdailybeacon.com\/do-you-wear-your-mask-when-you-are-walking-around-outdoors-on-campus\/poll_fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08.html?action=poll:results&format=json","chart":"bar"}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/ads/fixed-big-ad-bottom/2.js?_dc=1570543750"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/ads/fixed-big-ad-bottom/3.js?_dc=1579182514"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>Xbox Series X and PlayStation 5 release date, price unveiled, next generation of consoles on the horizon | Entertainment | utdailybeacon.com</title>
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.utdailybeacon.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/custom/image/51c7e558-e60d-11e5-bcbd-9bfb0af9b36a.png?resize=180%2C180" />
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//connect.facebook.net">
    <link rel="alternate" type="application/rss+xml" title="Xbox Series X and PlayStation 5 release date, price unveiled, next generation of consoles on the horizon | Entertainment | utdailybeacon.com" href="http://www.utdailybeacon.com/search/?f=rss&amp;t=article&amp;c=city_news/entertainment&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.utdailybeacon.com/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            
<meta name="GooGhywoiu9839t543j0s7543uw1. Please add john.r.kennedy@gmail.com to GA account UA-65761023 with “Manage Users and Edit” permissions - date 8th September 2016.">
<meta name="google-site-verification" content="jWba5pyWz1OgauMBvQngGeLgS0Nd6i8aChGSVuyzY9g" />

<!-- Flytedesk Digital -->
<!--#709258 -->
<script type="text/javascript">
(function (w, d, s, p) {
  let f = d.getElementsByTagName(s)[0], j = d.createElement(s);
  j.id = 'flytedigital';
  j.async = true;
  j.src = 'https://digital.flytedesk.com/js/head.js#' + p;
  f.parentNode.insertBefore(j, f);
})(window, document, 'script', '8b83122c-4b8d-48c2-9105-3f9a86c6eb0a');
</script>
<!-- End Flytedesk Digital -->







        </head>
        <body class="app-editorial grid-banded blox-asset uuid-66f6f9d2-fe95-11ea-b6aa-c765948b3777 section-city-newssection-entertainment type-article infinity-disabled" data-authors='["Seth Chapman"]' data-path="/city_news/entertainment">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.utdailybeacon.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.155.0&tncms.page.grid=banded&tncms.page.style=default&tncms.page.path=%2Fcity_news%2Fentertainment&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.asset.author=Seth+Chapman%2C+Staff+Writer&tncms.asset.id=66f6f9d2-fe95-11ea-b6aa-c765948b3777&tncms.asset.app=editorial&tncms.vendor.outbrain=disabled&tncms.vendor.taboola=&tncms.ad.vendor=blox&tncms.system.render_time=219&tncms.client.is_bot=yes&tncms.client.is_gdpr=no&tncms.google.ua=UA-65761023-1&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.utdailybeacon.com",
  secureDomain: "utdailybeacon.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/city_news\/entertainment","refresh":false}' style="display:none;"></div>
        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container"><div id="asset-contribute-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-certificate tnt-fw"></i></div>
                <div class="asset-edit-message">You are the owner of this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" href="https://www.utdailybeacon.com/users/https://www.utdailybeacon.com/tncms/admin/editorial-asset/?edit=66f6f9d2-fe95-11ea-b6aa-c765948b3777"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit Article</a>
                    
                        <a class="btn btn-danger btn-sm" href="https://www.utdailybeacon.com/users/admin/contribute/article/?from_section=/city_news/entertainment"><i class="fas tnt-plus tnt-fw"></i> Add New Article</a>
                    
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
            <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
            <div class="asset-edit-message">You have permission to edit this article.</div>
            <div class="asset-edit-btns">
                <a class="btn btn-primary btn-sm" href="https://www.utdailybeacon.com/tncms/admin/editorial-asset/?edit=66f6f9d2-fe95-11ea-b6aa-c765948b3777"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
            </div>
        </div>

    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-1211721" class="tncms-block hidden-md hidden-lg"><div id="user-controls-1211721" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.utdailybeacon.com/users/signup/?referer_url=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.utdailybeacon.com/users/login/?referer_url=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.utdailybeacon.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1211721').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.utdailybeacon.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.utdailybeacon.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.utdailybeacon.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1211721').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.utdailybeacon.com/users/logout/" id="user-logout-form-1211721"><input type="hidden" name="referer_url" value="https://www.utdailybeacon.com/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/special_sections/covid-19/"  class="nav-link tnt-section-covid-19">Covid-19</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/campus_news/"  class="nav-link tnt-section-campus-news">Campus News</a>
                                </li><li>
                                    <a href="/city_news/"  class="nav-link tnt-section-city-news">City News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/opinion/editorials"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a href="/opinion/columns/"  class="nav-link tnt-section-columns">Columns</a>
                                </li><li>
                                    <a href="/opinion/cartoons"  class="nav-link tnt-section-editorial-cartoons">Editorial Cartoons</a>
                                </li><li>
                                    <a href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters-to-editor">Letters to Editor</a>
                                </li><li>
                                    <a href="/site/forms/online_services/letter"  class="nav-link tnt-section-submit-a-letter">Submit a Letter</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/football"  class="nav-link tnt-section-football">Football</a>
                                </li><li>
                                    <a href="/sports/mens_basketball/"  class="nav-link tnt-section-mens-basketball">Men's Basketball</a>
                                </li><li>
                                    <a href="/sports/womens_basketball/"  class="nav-link tnt-section-womens-basketball">Women's Basketball</a>
                                </li><li>
                                    <a href="/sports/baseball"  class="nav-link tnt-section-baseball">Baseball</a>
                                </li><li>
                                    <a href="/sports/softball/"  class="nav-link tnt-section-softball">Softball</a>
                                </li><li>
                                    <a href="/sports/volleyball"  class="nav-link tnt-section-volleyball">Volleyball</a>
                                </li><li>
                                    <a href="/sports/soccer"  class="nav-link tnt-section-soccer">Soccer</a>
                                </li><li>
                                    <a href="/sports/golf"  class="nav-link tnt-section-golf">Golf</a>
                                </li><li>
                                    <a href="/sports/tennis"  class="nav-link tnt-section-tennis">Tennis</a>
                                </li><li>
                                    <a href="/sports/track_and_field/"  class="nav-link tnt-section-track-field-xc">Track & Field / XC</a>
                                </li><li>
                                    <a href="/sports/swimming/"  class="nav-link tnt-section-swimming-diving">Swimming & Diving</a>
                                </li><li>
                                    <a href="/sports/rowing/"  class="nav-link tnt-section-rowing">Rowing</a>
                                </li><li>
                                    <a href="/sports/intramural/"  class="nav-link tnt-section-intramural">Intramural</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-5" data-target="#mobile-nav-right_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/site/alumni_spotlight.html"  class="nav-link tnt-section-alumni-spotlight">Alumni Spotlight</a>
                                </li><li>
                                    <a href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a href="/site/staff.html"  class="nav-link tnt-section-staff">Staff</a>
                                </li><li>
                                    <a href="/site/editorial_policies.html"  class="nav-link tnt-section-editorial-policies">Editorial Policies</a>
                                </li><li>
                                    <a href="/site/corrections.html"  class="nav-link tnt-section-corrections">Corrections</a>
                                </li><li>
                                    <a href="/site/pickup_locations.html"  class="nav-link tnt-section-pickup-locations">Pickup Locations</a>
                                </li><li>
                                    <a href="/site/employment.html"  class="nav-link tnt-section-employment">Employment</a>
                                </li><li>
                                    <a href="/site/donate.html"  class="nav-link tnt-section-donate">Donate</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/site/advertise.html"  class="nav-link tnt-section-advertise">Advertise</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="http://www.utdailybeacon.com/2020-2021-rate-card/pdf_f4bbab24-c37f-11ea-84b7-af974b45abff.html"  target="_blank" rel="noopener" class="nav-link tnt-section-rate-card">Rate Card</a>
                                </li><li>
                                    <a href="/site/advertising_policies.html"  class="nav-link tnt-section-advertising-policies">Advertising Policies</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="https://www.utdailybeacon.com/site/forms/online_services/letter/application/"  target="_blank" rel="noopener" class="nav-link tnt-section-work-for-us">Work for Us</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/events/"  class="nav-link tnt-section-events">Events</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-1211706" class="tncms-block hidden-md hidden-lg"><section id="block-1211706" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1211706" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1211706" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-1211706-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1211706-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1211706-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1211706').submit();
        return false;
    });

    $('#site-search-1211706').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1211706 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1211706 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1211706-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    

    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    

    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>
                    

                    
                        <div class="navbar-brand pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1211697" class="tncms-block"><section id="block-1211697" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/custom/image/518c50ea-e783-11e8-87eb-6fa3ee004719.png?resize=200%2C401 200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/custom/image/518c50ea-e783-11e8-87eb-6fa3ee004719.png?resize=300%2C602 300w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/custom/image/518c50ea-e783-11e8-87eb-6fa3ee004719.png?resize=400%2C803 400w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/custom/image/518c50ea-e783-11e8-87eb-6fa3ee004719.png 540w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1211720" class="tncms-block"><div id="user-controls-1211720" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="nav navbar-nav navbar-right"><li><a  onclick="javascript:void(0); return false;"  data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" class="user-control-link" rel="nofollow">
                        <span class="fas tnt-user"></span>
                    </a>
                    <ul class="dropdown-menu dropdown-menu-right" role="menu">
                        <li>
                            <div style="width: 300px; padding: 15px">
                                <div class="row padding-bottom">
                                    <div class="col-md-12">
                                        <h4>Log In Using Your Account</h4>
                                        <a role="menuitem" class="btn btn-block btn-primary" href="https://www.utdailybeacon.com/users/login/?referer_url=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html" rel="nofollow">Log In</a>
                                    </div>
                                </div>
                                <div class="row">
                                    <div class="col-md-12">
                                        <div class="dropdown-signup"><strong>Don't have an account?</strong> <a role="menuitem" href="https://www.utdailybeacon.com/users/signup/?referer_url=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html" rel="nofollow">Sign Up Today</a></div>
                                    </div>
                                </div>
                            </div>
                        </li>
                    </ul>
                </li>
        </ul>
    </div>

    <div class="logged-in">
        
        
        <ul class="nav navbar-nav navbar-right">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.utdailybeacon.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.utdailybeacon.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.utdailybeacon.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1211720').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.utdailybeacon.com/users/logout/" id="user-logout-form-1211720"><input type="hidden" name="referer_url" value="https://www.utdailybeacon.com/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1211708" class="tncms-block header-social"><div class="follow-links-1211708 default">
    
    <section id="block-1211708" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href=" https://www.facebook.com/pages/The-Daily-Beacon/133245626686451" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/UTKDailyBeacon" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/channel/UCnSyMD9pu4AU7rJu0diGCNA" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://instagram.com/utkdailybeacon/?hl=en" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.utdailybeacon.com",
  "sameAs" : [" https://www.facebook.com/pages/The-Daily-Beacon/133245626686451","https://twitter.com/UTKDailyBeacon","https://www.youtube.com/channel/UCnSyMD9pu4AU7rJu0diGCNA","https://instagram.com/utkdailybeacon/?hl=en"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-1231239" class="tncms-block"><ul id="site-search-1231239-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1231239" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default input-group-lg ">
        <input id="site-search-1231239-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1231239-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-1231239-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1231239').submit();
        return false;
    });

    $('#site-search-1231239').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1231239 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1231239 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1231239-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link  tnt-section-covid-19"  href="/special_sections/covid-19/" >
                    <span class="nav-label">Covid-19</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-campus-news"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/campus_news/" >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Campus News</span>
                </a><ul id="main-nav_menu-child-2-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-campus-life"  href="/campus_news/campus_life/" >
                    <span class="nav-label">Campus Life</span>
                </a></li><li>
                <a class="nav-link  tnt-section-science-and-medicine"  href="/campus_news/science_and_medicine/" >
                    <span class="nav-label">Science and Medicine</span>
                </a></li><li>
                <a class="nav-link  tnt-section-special-issues"  href="/campus_news/special_issues" >
                    <span class="nav-label">Special Issues</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-city-news"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/city_news/" >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">City News</span>
                </a><ul id="main-nav_menu-child-2-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-fashion"  href="/city_news/fashion/" >
                    <span class="nav-label">Fashion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-entertainment"  href="/city_news/entertainment/" >
                    <span class="nav-label">Entertainment</span>
                </a></li><li>
                <a class="nav-link  tnt-section-music"  href="/city_news/music/" >
                    <span class="nav-label">Music</span>
                </a></li><li>
                <a class="nav-link  tnt-section-lifestyle"  href="/city_news/lifestyle/" >
                    <span class="nav-label">Lifestyle</span>
                </a></li><li>
                <a class="nav-link  tnt-section-food"  href="/city_news/food" >
                    <span class="nav-label">Food</span>
                </a></li></ul></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion" >
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-editorials"  href="/opinion/editorials" >
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link  tnt-section-columns"  href="/opinion/columns/" >
                    <span class="nav-label">Columns</span>
                </a></li><li>
                <a class="nav-link  tnt-section-editorial-cartoons"  href="/opinion/cartoons" >
                    <span class="nav-label">Editorial Cartoons</span>
                </a></li><li>
                <a class="nav-link  tnt-section-letters-to-editor"  href="/opinion/letters_to_editor/" >
                    <span class="nav-label">Letters to Editor</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-a-letter"  href="/site/forms/online_services/letter" >
                    <span class="nav-label">Submit a Letter</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports" >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-football"  href="/sports/football" >
                    <span class="nav-label">Football</span>
                </a></li><li>
                <a class="nav-link  tnt-section-mens-basketball"  href="/sports/mens_basketball/" >
                    <span class="nav-label">Men's Basketball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-womens-basketball"  href="/sports/womens_basketball/" >
                    <span class="nav-label">Women's Basketball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-baseball"  href="/sports/baseball" >
                    <span class="nav-label">Baseball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-softball"  href="/sports/softball/" >
                    <span class="nav-label">Softball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-volleyball"  href="/sports/volleyball" >
                    <span class="nav-label">Volleyball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-soccer"  href="/sports/soccer" >
                    <span class="nav-label">Soccer</span>
                </a></li><li>
                <a class="nav-link  tnt-section-golf"  href="/sports/golf" >
                    <span class="nav-label">Golf</span>
                </a></li><li>
                <a class="nav-link  tnt-section-tennis"  href="/sports/tennis" >
                    <span class="nav-label">Tennis</span>
                </a></li><li>
                <a class="nav-link  tnt-section-track-field-xc"  href="/sports/track_and_field/" >
                    <span class="nav-label">Track & Field / XC</span>
                </a></li><li>
                <a class="nav-link  tnt-section-swimming-diving"  href="/sports/swimming/" >
                    <span class="nav-label">Swimming & Diving</span>
                </a></li><li>
                <a class="nav-link  tnt-section-rowing"  href="/sports/rowing/" >
                    <span class="nav-label">Rowing</span>
                </a></li><li>
                <a class="nav-link  tnt-section-intramural"  href="/sports/intramural/" >
                    <span class="nav-label">Intramural</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-about-us"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-alumni-spotlight"  href="/site/alumni_spotlight.html" >
                    <span class="nav-label">Alumni Spotlight</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-staff"  href="/site/staff.html" >
                    <span class="nav-label">Staff</span>
                </a></li><li>
                <a class="nav-link  tnt-section-editorial-policies"  href="/site/editorial_policies.html" >
                    <span class="nav-label">Editorial Policies</span>
                </a></li><li>
                <a class="nav-link  tnt-section-corrections"  href="/site/corrections.html" >
                    <span class="nav-label">Corrections</span>
                </a></li><li>
                <a class="nav-link  tnt-section-pickup-locations"  href="/site/pickup_locations.html" >
                    <span class="nav-label">Pickup Locations</span>
                </a></li><li>
                <a class="nav-link  tnt-section-employment"  href="/site/employment.html" >
                    <span class="nav-label">Employment</span>
                </a></li><li>
                <a class="nav-link  tnt-section-donate"  href="/site/donate.html" >
                    <span class="nav-label">Donate</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-advertise"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/site/advertise.html" >
                    <span class="nav-label">Advertise</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-rate-card"  href="http://www.utdailybeacon.com/2020-2021-rate-card/pdf_f4bbab24-c37f-11ea-84b7-af974b45abff.html"  target="_blank" rel="noopener">
                    <span class="nav-label">Rate Card</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertising-policies"  href="/site/advertising_policies.html" >
                    <span class="nav-label">Advertising Policies</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-work-for-us"  href="https://www.utdailybeacon.com/site/forms/online_services/letter/application/"  target="_blank" rel="noopener">
                    <span class="nav-label">Work for Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-events"  href="/events/" >
                    <span class="nav-label">Events</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1278649" class="tncms-block padding-top">
        <div id="blox-ad-position-pencil1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"pencil","slot":"1","fold":"","width":"960","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1211608" class="tncms-block hidden-xs padding-top padding-bottom">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1211609" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><div class="modal fullscreen" id="photo-carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777" tabindex="-1" role="dialog" aria-labelledby="photo-carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777" aria-hidden="true">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-body">
                    <button type="button" class="close" data-dismiss="modal">
                        <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                        <span class="sr-only">Close</span>
                    </button>
                    
    <div id="carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal" class="card photo-carousel    subscriber-hide letterbox-style-default">
            
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 2
                    </span>
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            
            <div id="gallery-items-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal" class="carousel-inner"><div  class="item photo-f4d0bbb8-fe94-11ea-bc0e-9f7813158a82">
                            <div class="item-container">
				                <div data-track-object='{"title":"Xbox Series X and PlayStation 5 release date, price unveiled, next generation of consoles on the horizon","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=1200%2C675"
                    
                    alt="Xbox Series X and S"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1280"
                    height="720"
                    data-src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=1200%2C675" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal" data-target=".caption-inner-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span  class="tnt-byline">Courtesy of Microsoft</span></li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.utdailybeacon.com%2Fxbox-series-x-and-s%2Fimage_f4d0bbb8-fe94-11ea-bc0e-9f7813158a82.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/xbox-series-x-and-s/image_f4d0bbb8-fe94-11ea-bc0e-9f7813158a82.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f4d0bbb8-fe94-11ea-bc0e-9f7813158a82"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Xbox%20Series%20X%20and%20S&via=UTKDailyBeacon&url=https%3A%2F%2Fwww.utdailybeacon.com%2Fxbox-series-x-and-s%2Fimage_f4d0bbb8-fe94-11ea-bc0e-9f7813158a82.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/xbox-series-x-and-s/image_f4d0bbb8-fe94-11ea-bc0e-9f7813158a82.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f4d0bbb8-fe94-11ea-bc0e-9f7813158a82"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.utdailybeacon.com/xbox-series-x-and-s/image_f4d0bbb8-fe94-11ea-bc0e-9f7813158a82.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/xbox-series-x-and-s/image_f4d0bbb8-fe94-11ea-bc0e-9f7813158a82.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f4d0bbb8-fe94-11ea-bc0e-9f7813158a82"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.utdailybeacon.com/tncms/asset/editorial/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"f4d0bbb8-fe94-11ea-bc0e-9f7813158a82"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BUniversity%20of%20Tennessee%20Daily%20Beacon%5D%20Xbox%20Series%20X%20and%20S&body=https%3A%2F%2Fwww.utdailybeacon.com%2Fxbox-series-x-and-s%2Fimage_f4d0bbb8-fe94-11ea-bc0e-9f7813158a82.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"f4d0bbb8-fe94-11ea-bc0e-9f7813158a82"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/xbox-series-x-and-s/image_f4d0bbb8-fe94-11ea-bc0e-9f7813158a82.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f4d0bbb8-fe94-11ea-bc0e-9f7813158a82"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-f4d0bbb8-fe94-11ea-bc0e-9f7813158a82-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="f4d0bbb8-fe94-11ea-bc0e-9f7813158a82" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="f4d0bbb8-fe94-11ea-bc0e-9f7813158a82" class="save-list-f4d0bbb8-fe94-11ea-bc0e-9f7813158a82-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="f4d0bbb8-fe94-11ea-bc0e-9f7813158a82" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div><div  class="item photo-01c84e58-fe95-11ea-81b3-7b06e595ba26">
                            <div class="item-container">
				                <div data-track-object='{"title":"Xbox Series X and PlayStation 5 release date, price unveiled, next generation of consoles on the horizon","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-horizontal"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/0/1c/01c84e58-fe95-11ea-81b3-7b06e595ba26/5f6ce79a6f0c4.image.jpg?resize=1200%2C800"
                    
                    alt="PlayStation 5"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1763"
                    height="1175"
                    data-src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/0/1c/01c84e58-fe95-11ea-81b3-7b06e595ba26/5f6ce79a6f0c4.image.jpg?resize=1200%2C800" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal" data-target=".caption-inner-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span  class="tnt-byline">Courtesy of Sony</span></li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.utdailybeacon.com%2Fplaystation-5%2Fimage_01c84e58-fe95-11ea-81b3-7b06e595ba26.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/playstation-5/image_01c84e58-fe95-11ea-81b3-7b06e595ba26.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"01c84e58-fe95-11ea-81b3-7b06e595ba26"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=PlayStation%205&via=UTKDailyBeacon&url=https%3A%2F%2Fwww.utdailybeacon.com%2Fplaystation-5%2Fimage_01c84e58-fe95-11ea-81b3-7b06e595ba26.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/playstation-5/image_01c84e58-fe95-11ea-81b3-7b06e595ba26.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"01c84e58-fe95-11ea-81b3-7b06e595ba26"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.utdailybeacon.com/playstation-5/image_01c84e58-fe95-11ea-81b3-7b06e595ba26.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/playstation-5/image_01c84e58-fe95-11ea-81b3-7b06e595ba26.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"01c84e58-fe95-11ea-81b3-7b06e595ba26"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.utdailybeacon.com/tncms/asset/editorial/01c84e58-fe95-11ea-81b3-7b06e595ba26" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"01c84e58-fe95-11ea-81b3-7b06e595ba26"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BUniversity%20of%20Tennessee%20Daily%20Beacon%5D%20PlayStation%205&body=https%3A%2F%2Fwww.utdailybeacon.com%2Fplaystation-5%2Fimage_01c84e58-fe95-11ea-81b3-7b06e595ba26.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"01c84e58-fe95-11ea-81b3-7b06e595ba26"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/playstation-5/image_01c84e58-fe95-11ea-81b3-7b06e595ba26.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"01c84e58-fe95-11ea-81b3-7b06e595ba26"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-01c84e58-fe95-11ea-81b3-7b06e595ba26-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="01c84e58-fe95-11ea-81b3-7b06e595ba26" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="01c84e58-fe95-11ea-81b3-7b06e595ba26" class="save-list-01c84e58-fe95-11ea-81b3-7b06e595ba26-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="01c84e58-fe95-11ea-81b3-7b06e595ba26" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </div>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-66f6f9d2-fe95-11ea-b6aa-c765948b3777" class="asset article-default"  data-url="https://www.utdailybeacon.com/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=1120%2C630">
            <meta itemprop="width" content="1120">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="utdailybeacon.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.utdailybeacon.com/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html" />
    <style>
                .asset-paging .direction {
                    color: #DCD2CD;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.utdailybeacon.com\/tncms\/search\/mlt\/?origin=66f6f9d2-fe95-11ea-b6aa-c765948b3777&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-66f6f9d2-fe95-11ea-b6aa-c765948b3777" class="asset-paging">
                <div id="paging-prev-66f6f9d2-fe95-11ea-b6aa-c765948b3777" class="paging-link prev offset"></div>
                <div id="paging-next-66f6f9d2-fe95-11ea-b6aa-c765948b3777" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Xbox Series X and PlayStation 5 release date, price unveiled, next generation of consoles on the horizon
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-popup-a5d59f46-60b1-11ea-9f88-4b5abd4c3984-asset-66f6f9d2-fe95-11ea-b6aa-c765948b3777" class="tnt-byline asset-byline" rel="popover" itemprop="author"><a href="https://www.utdailybeacon.com/users/profile/Seth%20Chapman">Seth Chapman, Staff Writer</a></span>
                
                    <div id="author-popup-a5d59f46-60b1-11ea-9f88-4b5abd4c3984-asset-66f6f9d2-fe95-11ea-b6aa-c765948b3777-content" class="hide">
                        <article class="clearfix card author popup-content card-author-a5d59f46-60b1-11ea-9f88-4b5abd4c3984">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.utdailybeacon.com/users/profile/Seth%20Chapman" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        
    
        <img
            alt="Seth Chapman"
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
            data-src="https://secure.gravatar.com/avatar/de72b1eb5148e3dc26479f0805ec2671?s=100&d=mm&r=g"
            class="img-responsive lazyload tnt-user-avatar" />
    

                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.utdailybeacon.com/users/profile/Seth%20Chapman" rel="author" class="tnt-user-profile-link tnt-user-name">Seth Chapman</a>
                                </h4></div>
                        </div>
                    </div>
                </div>
            </article>
                    </div>
                    <script>
                        $('#author-popup-a5d59f46-60b1-11ea-9f88-4b5abd4c3984-asset-66f6f9d2-fe95-11ea-b6aa-c765948b3777').popover({
                            content: $('#author-popup-a5d59f46-60b1-11ea-9f88-4b5abd4c3984-asset-66f6f9d2-fe95-11ea-b6aa-c765948b3777-content').html(),
                            container: 'body',
                            html:true,
                            sanitize: false,
                            trigger:'hover',
                            placement:'top',
                            delay:{ show:100, hide:200 }
                        });
                    </script>
                </li>
        
        
            <li class="visible-print">
        <time datetime="2020-09-24T14:40:00-04:00" class="tnt-date asset-date text-muted">
            Sep 24, 2020
        </time></li>
            <li class="hidden-print"><time datetime="2020-09-24T14:40:00-04:00" class="tnt-date asset-date text-muted">Sep 24, 2020</time>
        <span class="text-muted tnt-update-recent">Updated </span>
        <time datetime="2020-09-24T14:41:43-04:00" class="tnt-date tnt-update-recent asset-date text-muted">3 hrs ago</time>
    </li>
        
        
            <li class="hidden-print"><a href="/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html#comments" class="cm"><span class="fas tnt-comments"></span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-09-24T14:40:00-04:00">
    <meta itemprop="datePublished" content="2020-09-24T14:40:00-04:00">
    <meta itemprop="dateModified" content="2020-09-24T10:41:43-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Xbox%20Series%20X%20and%20PlayStation%205%20release%20date%2C%20price%20unveiled%2C%20next%20generation%20of%20consoles%20on%20the%20horizon&via=UTKDailyBeacon&url=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.utdailybeacon.com/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.utdailybeacon.com/tncms/asset/editorial/66f6f9d2-fe95-11ea-b6aa-c765948b3777" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BUniversity%20of%20Tennessee%20Daily%20Beacon%5D%20Xbox%20Series%20X%20and%20PlayStation%205%20release%20date%2C%20price%20unveiled%2C%20next%20generation%20of%20consoles%20on%20the%20horizon&body=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="66f6f9d2-fe95-11ea-b6aa-c765948b3777">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Xbox%20Series%20X%20and%20PlayStation%205%20release%20date%2C%20price%20unveiled%2C%20next%20generation%20of%20consoles%20on%20the%20horizon&via=UTKDailyBeacon&url=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.utdailybeacon.com/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.utdailybeacon.com/tncms/asset/editorial/66f6f9d2-fe95-11ea-b6aa-c765948b3777" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BUniversity%20of%20Tennessee%20Daily%20Beacon%5D%20Xbox%20Series%20X%20and%20PlayStation%205%20release%20date%2C%20price%20unveiled%2C%20next%20generation%20of%20consoles%20on%20the%20horizon&body=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-66f6f9d2-fe95-11ea-b6aa-c765948b3777-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="66f6f9d2-fe95-11ea-b6aa-c765948b3777" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="66f6f9d2-fe95-11ea-b6aa-c765948b3777" class="save-list-66f6f9d2-fe95-11ea-b6aa-c765948b3777-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="66f6f9d2-fe95-11ea-b6aa-c765948b3777" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p><span>After what felt like a months-long standoff between the two companies, we finally have definitive details on the release date and prices of the next-gen consoles.</span></p><p><span>Starting off with Xbox, the possible price of the system had leaked online. However, the big surprise wasn’t exactly the price. Instead, it was the reveal of a </span><em>second </em><span>next-gen Xbox. Dubbed the Series S, this new Xbox is noticeably smaller than its larger brother and its flat design makes it look like a speaker device.</span></p><p><span>On the Xbox website, Phil Spencer, the Head of Xbox, shared more details about the Series S console.</span></p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/city_news\/entertainment","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><div class="inline-asset inline-image layout-horizontal  subscriber-hide  tnt-inline-asset tnt-inline-relcontent tnt-inline-image tnt-inline-relation-child tnt-inline-presentation-default tnt-inline-alignment-default tnt-inline-width-default"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-f4d0bbb8-fe94-11ea-bc0e-9f7813158a82" 
                    data-instance="#gallery-items-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal" 
                    data-target="#photo-carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777">
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-f4d0bbb8-fe94-11ea-bc0e-9f7813158a82" 
                    data-instance="#gallery-items-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal" 
                    data-target="#photo-carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777">
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1280">
            <meta itemprop="height" content="720">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=1200%2C675">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=1200%2C675">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Xbox Series X and S"
                            class="img-responsive lazyload full default"
                            width="1280"
                            height="720"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=200%2C113 200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=300%2C169 300w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=400%2C225 400w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=540%2C304 540w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=750%2C422 750w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=1200%2C675 1200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/f/4d/f4d0bbb8-fe94-11ea-bc0e-9f7813158a82/5f6ce769beb35.image.jpg?resize=1280%2C720 1700w" />
            </div>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                        
                            <span class="credit">
                                <span itemprop="author" class="tnt-byline">Courtesy of Microsoft</span>
                            </span>
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div><p><span>“We believe that access to the next generation should be available to everyone. And we know that price is an important factor for many of our fans,” Spencer said. “To complement Xbox Series X and invite more players into the next generation sooner, we built Xbox Series S — an all-digital, next-gen console designed to deliver everything that is core to next-generation gaming – faster load times, higher frame rates, and richer, more dynamic worlds – in our smallest, sleekest Xbox ever.”</span></p><p><span>Affordability does seem to be the key feature of the Series S, especially with it coming in at the surprisingly low price of $299.99. While it lacks certain features of its older brother, such as native 4K, smaller internal memory and a built-in disc drive, it does make for an appealing entry point into next-gen gaming. </span></p><p><span>Just to give you an idea, the Series X is priced at $499.99. This system, in conjunction with Game Pass, could make it a lucrative offer for gamers who can’t quite afford the $500 price tag yet.</span></p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle-asset","id":"fixed-big-ad-middle-asset","pos":"fixed-big-ad-middle-asset, stf","fold":"span","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/city_news\/entertainment","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle-asset', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p><span>On the PlayStation side of things, they also have a few surprises. The price of the PS5 is $499.99. However, the all-digital version that was showcased along with the base PS5 is priced at $399.99, a hundred dollars less than a base PS5. </span></p><p><span>In addition to this news, PlayStation has also made some significant news about its first party titles. On the PlayStation blog, Sony revealed that Marvel’s Spider-Man: Miles Morales, Sackboy A Big Adventure and Horizon Forbidden West will also release on PS4. Players who purchase the PS4 versions of these games will also receive free upgrades to the PS5 version.</span></p><p><span>If you are a PlayStation Plus subscriber, you will also receive access to the PlayStation Plus Collection. Jim Ryan, President and CEO of Sony Interactive Entertainment, detailed the new service on the PlayStation blog.</span></p><div class="inline-asset inline-image layout-horizontal  subscriber-hide  tnt-inline-asset tnt-inline-relcontent tnt-inline-image tnt-inline-relation-child tnt-inline-presentation-default tnt-inline-alignment-default tnt-inline-width-default"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-01c84e58-fe95-11ea-81b3-7b06e595ba26" 
                    data-instance="#gallery-items-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal" 
                    data-target="#photo-carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777">
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-01c84e58-fe95-11ea-81b3-7b06e595ba26" 
                    data-instance="#gallery-items-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal" 
                    data-target="#photo-carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777">
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1763">
            <meta itemprop="height" content="1175">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/0/1c/01c84e58-fe95-11ea-81b3-7b06e595ba26/5f6ce79a6f0c4.image.jpg?resize=1200%2C800">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/0/1c/01c84e58-fe95-11ea-81b3-7b06e595ba26/5f6ce79a6f0c4.image.jpg?resize=1200%2C800">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="PlayStation 5"
                            class="img-responsive lazyload full default"
                            width="1763"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/0/1c/01c84e58-fe95-11ea-81b3-7b06e595ba26/5f6ce79a6f0c4.image.jpg?resize=200%2C133 200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/0/1c/01c84e58-fe95-11ea-81b3-7b06e595ba26/5f6ce79a6f0c4.image.jpg?resize=300%2C200 300w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/0/1c/01c84e58-fe95-11ea-81b3-7b06e595ba26/5f6ce79a6f0c4.image.jpg?resize=400%2C267 400w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/0/1c/01c84e58-fe95-11ea-81b3-7b06e595ba26/5f6ce79a6f0c4.image.jpg?resize=540%2C360 540w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/0/1c/01c84e58-fe95-11ea-81b3-7b06e595ba26/5f6ce79a6f0c4.image.jpg?resize=750%2C500 750w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/0/1c/01c84e58-fe95-11ea-81b3-7b06e595ba26/5f6ce79a6f0c4.image.jpg?resize=1200%2C800 1200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/0/1c/01c84e58-fe95-11ea-81b3-7b06e595ba26/5f6ce79a6f0c4.image.jpg?resize=1700%2C1133 1700w" />
            </div>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                        
                            <span class="credit">
                                <span itemprop="author" class="tnt-byline">Courtesy of Sony</span>
                            </span>
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div><p><span>“For PlayStation Plus members, we’ll have a special new offering on PS5 – the PlayStation Plus Collection. PS5 owners with PS Plus will be able to download and play a curated library of PS4 games that defined the generation, like Batman Arkham Knight, Bloodborne, Fallout 4, God of War, Monster Hunter: World, Persona 5 and many more,” Ryan said. “The PS Plus Collection will be an added benefit to the existing PS4 benefits that PS Plus members receive for a single subscription price.”</span></p><p><span>This PlayStation Plus Collection allows PS5 owners access to some of the best games of the previous generation on top of the benefits that already come with being a PS Plus member.</span></p><p><span>The Series S and X are slated to release on Nov. 10, and the PS5 will release shortly after on Nov. 12. </span></p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/city_news\/entertainment","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Xbox%20Series%20X%20and%20PlayStation%205%20release%20date%2C%20price%20unveiled%2C%20next%20generation%20of%20consoles%20on%20the%20horizon&via=UTKDailyBeacon&url=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.utdailybeacon.com/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.utdailybeacon.com/tncms/asset/editorial/66f6f9d2-fe95-11ea-b6aa-c765948b3777" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BUniversity%20of%20Tennessee%20Daily%20Beacon%5D%20Xbox%20Series%20X%20and%20PlayStation%205%20release%20date%2C%20price%20unveiled%2C%20next%20generation%20of%20consoles%20on%20the%20horizon&body=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/city_news/entertainment/xbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on/article_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66f6f9d2-fe95-11ea-b6aa-c765948b3777"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-66f6f9d2-fe95-11ea-b6aa-c765948b3777-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="66f6f9d2-fe95-11ea-b6aa-c765948b3777" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="66f6f9d2-fe95-11ea-b6aa-c765948b3777" class="save-list-66f6f9d2-fe95-11ea-b6aa-c765948b3777-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="66f6f9d2-fe95-11ea-b6aa-c765948b3777" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    
                        
                            <div class="asset-author">
                                <article class="clearfix card author  card-author-a5d59f46-60b1-11ea-9f88-4b5abd4c3984">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.utdailybeacon.com/users/profile/Seth%20Chapman" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        
    
        <img
            alt="Seth Chapman"
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
            data-src="https://secure.gravatar.com/avatar/de72b1eb5148e3dc26479f0805ec2671?s=100&d=mm&r=g"
            class="img-responsive lazyload tnt-user-avatar" />
    

                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.utdailybeacon.com/users/profile/Seth%20Chapman" rel="author" class="tnt-user-profile-link tnt-user-name">Seth Chapman</a>
                                </h4><div class="followed-notify-link hidden-print"><button id="follow-author-a5d59f46-60b1-11ea-9f88-4b5abd4c3984" class="followed-notify-btn btn btn-success btn-sm" disabled data-params="?a=a5d59f46-60b1-11ea-9f88-4b5abd4c3984&amp;s=start_time&amp;sd=desc" data-subject="Seth Chapman" data-description="Whenever Seth Chapman posts new content, you'll get an email delivered to your inbox with a link." data-name="Seth Chapman notification" data-author-id="a5d59f46-60b1-11ea-9f88-4b5abd4c3984" data-user-url="https://www.utdailybeacon.com/users/">
        <i class="fas tnt-star"></i> Follow Seth Chapman
    </button><template id="follow-this-modal-logged-in">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Get email notifications on {{subject}} daily!</h4>
                    </div>
                    <div class="modal-body">
                        <div class="alert alert-success" style="display:none;">
                            Your notification has been saved.
                        </div>
                        <div class="alert alert-danger" style="display:none;">
                            There was a problem saving your notification.
                        </div>
                        <p class="notification-description">{{description}}</p>
                        <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                        <form id="follow-notify-form" class="follow-notify-form" action="{{action}}" method="post">
                            <input class="input-notification-name" type="hidden" name="title" value="{{title}}">
                            <div class="row">
                                <div class="col-sm-6">
                                    <button class="btn btn-success btn-block follow-btn" >
                                        <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                    </button>
                                </div>
                                <div class="col-sm-6">
                                    <a class="btn btn-default btn-block" href="https://www.utdailybeacon.com/users/admin/savedsearch/">Manage followed notifications</a>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </template>

        <template id="follow-this-modal-logged-out">
            <div class="modal-dialog modal-sm">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Followed notifications</h4>
                    </div>
                    <div class="modal-body">
                        <div class="user-login padding-bottom">
                            <h4>Please log in to use this feature</h4>
                            <a class="btn btn-block btn-primary" href="https://www.utdailybeacon.com/users/login/?referer_url=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html" rel="nofollow">Log In</a>
                        </div>
                        <div class="user-signup">
                            <strong>Don't have an account?</strong> <a href="https://www.utdailybeacon.com/users/signup/?referer_url=https%3A%2F%2Fwww.utdailybeacon.com%2Fcity_news%2Fentertainment%2Fxbox-series-x-and-playstation-5-release-date-price-unveiled-next-generation-of-consoles-on%2Farticle_66f6f9d2-fe95-11ea-b6aa-c765948b3777.html" rel="nofollow">Sign Up Today</a>
                        </div>
                    </div>
                </div>
            </div>
        </template>

        <div id="follow-this-modal" class="modal fade follow-this-modal">
            <div class="modal-dialog"></div>
        </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
                            </div>
                        
                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1436398" class="tncms-block"><div id="utcommmktgad">
<link rel="stylesheet" type="text/css" href="http://35.185.105.190/adserver/css/style.css">
<p class="UTSponsoredContent">UT Sponsored Content</p>
<ins data-revive-zoneid="3" data-revive-block="1" data-revive-withtext="1" data-revive-id="d8291cb3e20fbfbba1c4cba4111eadf8"></ins>
<ins data-revive-zoneid="4" data-revive-block="1" data-revive-id="d8291cb3e20fbfbba1c4cba4111eadf8"></ins>
<ins data-revive-zoneid="5" data-revive-block="1" data-revive-id="d8291cb3e20fbfbba1c4cba4111eadf8"></ins>
<script async src="//35.185.105.190/adserver/www/delivery/asyncjs.php"></script>
</div></div></div>

                    <div class="asset-comments hidden-print">
                
                <div id="comments-container" class="comments-container">
                    
                    <div
                        id="comments" 
                        class="fb-comments" 
                        data-href="http://www.utdailybeacon.com/tncms/asset/editorial/66f6f9d2-fe95-11ea-b6aa-c765948b3777/" 
                        data-num-posts="10" 
                        data-width="100%" 
                    ></div>
                    <style>
                        .fb_iframe_widget,
                        .fb_iframe_widget span,
                        .fb_iframe_widget span iframe[style]{
                            min-width:100%!important;
                            width:100%!important;
                        }
                    </style>
                </div>
            
        </div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/city_news\/entertainment","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1211677" class="tncms-block"><section id="block-1211677" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1211677 ">
        <div class="block-title-inner">
            <h3>
                
                Beacon Poll
                
            </h3>
        </div>
    </div></div>
        
            
                <div class="poll-panel panel">
                    <div class="panel-body">
            
            <h4 class="tnt-headline ">
        
             <a href="/do-you-wear-your-mask-when-you-are-walking-around-outdoors-on-campus/poll_fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08.html" class="tnt-asset-link">
        

        
            Do you wear your mask when you are walking around outdoors on campus?</a></h4>
            <div id="poll-fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08-1211677" data-charted="false" class="card poll-content"><div class="loading-poll hide-onload text-center"><i class="fas tnt-spinner tnt-spin tnt-2x"></i></div>
            <div class="show-onload">
                <div id="poll-fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08-1211677-your-vote-container" class="alert alert-warning hide">
                    <strong>You voted:</strong> <span id="poll-fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08-1211677-your-vote"></span>
                </div>
                <div id="poll-fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08-1211677-results" class="tnt-poll-results hide"></div>
                <div id="poll-fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08-1211677-container">
                    <form id="poll-fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08-1211677-form" class="tnt-poll-form" role="form" method="post" action="/do-you-wear-your-mask-when-you-are-walking-around-outdoors-on-campus/poll_fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08.html">
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Yes" value="C9127E52-4A00-0001-2C4941601E121AF7"> Yes
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="No" value="C9127E53-1330-0001-5AD7D0C963201768"> No
                                </label>
                            </div>
                        
                        <button type="submit" class="btn btn-primary" >Vote</button>
                        <button id="poll-fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08-1211677-get-results" class="btn btn-default" >View Results</button>
                    </form>
                </div>
            </div>
            <div id="poll-fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08-1211677-back-vote" class="padding-top hide">
                <button id="poll-fd4c8b2a-feab-11ea-8156-c7bb3b4e6c08-1211677-back-btn" class="btn btn-default">Back</button>
            </div>
        </div>
            
                    </div>
                </div>
            
        
    </section></div><div id="tncms-block-1696244" class="tncms-block"><div class="padding-top padding-bottom text-center">
<!--<div class="flytead rectangle 8b83122c-70a6-4016-9072-4bb02a0648f7"></div>-->
<div class="flytead rectangle
8b83122c-70a6-4016-9072-4bb02a0648f7"></div>
</div></div><div id="tncms-block-1238956" class="tncms-block"><section id="block-1238956" class="block emphasis-h3   " ><div id="html-asset-1238956">
            <div class="html-content"><!--Begin CTCT Sign-Up Form-->
<!-- EFD 1.0.0 [Tue May 03 09:34:47 EDT 2016] -->
<link rel='stylesheet' type='text/css' href='https://static.ctctcdn.com/h/contacts-embedded-signup-assets/1.0.2/css/signup-form.css'>
<div class="ctct-embed-signup" style="font: 16px Helvetica Neue, Arial, sans-serif; font: 1rem Helvetica Neue, Arial, sans-serif; line-height: 1.5; -webkit-font-smoothing: antialiased;">
   <div style="color:#5b5b5b; background-color:#e8e8e8; border-radius:5px;">
       <span id="success_message" style="display:none;">
           <div style="text-align:center;">Thanks for signing up!</div>
       </span>
       <form data-id="embedded_signup:form" class="ctct-custom-form Form" name="embedded_signup" method="POST" action="https://visitor2.constantcontact.com/api/signup">
           <h2 style="margin:0;">Beacon Newsletter</h2>
           <p>Get the top stories from campus and around Knoxville.</p>
           <!-- The following code must be included to ensure your sign-up form works properly. -->
           <input data-id="ca:input" type="hidden" name="ca" value="d6ef10cd-3412-4e0b-bdeb-b981811a0363">
           <input data-id="list:input" type="hidden" name="list" value="1741811566">
           <input data-id="source:input" type="hidden" name="source" value="EFD">
           <input data-id="required:input" type="hidden" name="required" value="list,email">
           <input data-id="url:input" type="hidden" name="url" value="">
           <p data-id="Email Address:p" ><label data-id="Email Address:label" data-name="email" class="ctct-form-required">Email Address</label> <input data-id="Email Address:input" type="text" name="email" value="" maxlength="80"></p>
           <button type="submit" class="Button ctct-button Button--block Button-secondary" data-enabled="enabled">Sign Up</button>
       	<div><p class="ctct-form-footer">By submitting this form, you are granting: The Daily Beacon, , , , , , http://utdailybeacon-com.chicago2.cms.townnews-staging.com permission to email you. You may unsubscribe via the link found at the bottom of every email.  (See our <a href="http://www.constantcontact.com/legal/privacy-statement" target="_blank">Email Privacy Policy</a> for details.) Emails are serviced by Constant Contact.</p></div>
       </form>
   </div>
</div>
<script type='text/javascript'>
   var localizedErrMap = {};
   localizedErrMap['required'] = 		'This field is required.';
   localizedErrMap['ca'] = 			'An unexpected error occurred while attempting to send email.';
   localizedErrMap['email'] = 			'Please enter your email address in name@email.com format.';
   localizedErrMap['birthday'] = 		'Please enter birthday in MM/DD format.';
   localizedErrMap['anniversary'] = 	'Please enter anniversary in MM/DD/YYYY format.';
   localizedErrMap['custom_date'] = 	'Please enter this date in MM/DD/YYYY format.';
   localizedErrMap['list'] = 			'Please select at least one email list.';
   localizedErrMap['generic'] = 		'This field is invalid.';
   localizedErrMap['shared'] = 		'Sorry, we could not complete your sign-up. Please contact us to resolve this.';
   localizedErrMap['state_mismatch'] = 'Mismatched State/Province and Country.';
	localizedErrMap['state_province'] = 'Select a state/province';
   localizedErrMap['selectcountry'] = 	'Select a country';
   var postURL = 'https://visitor2.constantcontact.com/api/signup';
</script>
<script type='text/javascript' src='https://static.ctctcdn.com/h/contacts-embedded-signup-assets/1.0.2/js/signup-form.js'></script>
<!--End CTCT Sign-Up Form--></div>
        </div></section></div><div id="tncms-block-1212076" class="tncms-block"><section id="block-1212076" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1212076 ">
        <div class="block-title-inner">
            <h3>
                
                Most Recent Videos
                
            </h3>
        </div>
    </div></div>
    <div class="card-grid card-img- card-bg-color">
        <div class="row">
                    <div class="card col-sm-12">
                        <div class="card-panel panel">
                                <div class="panel-body">
                        


<article id="card-showcase-e9efa63c-fe03-11ea-be0c-63f2aaab7b07" class="clearfix card showcase position-0 odd  tnt-section-city-news">
            <div class="card-container"><div class="card-image ">
                <div class="media-preview-e9efa63c-fe03-11ea-be0c-63f2aaab7b07 media-preview video-asset" data-aspect="16:9"><div class="tnt-video-container video-responsive" data-provider="youtube"  data-projection="" ><iframe height="270" width="480" allow="autoplay; encrypted-media" src="https://www.youtube.com/embed/pXQoTHN6r9E?" frameborder="0" allowfullscreen></iframe></div>
<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "VideoObject",
                "name": "What to Watch Wednesday: S3E4",
                "description": "In this episode, Jake talks about Break the Silence: The Movie, Akira 4K, Enola Holmes, and Secret Society of Second-Born Royals. Check out What to Watch Wednesday every week to stay up to date with new movies releasing in theaters near you! Shot and Edited by Kailee Harris ------------------------------------------------------------------------------------------------------------ Follow us on Social Media! Facebook: https://www.facebook.com/UTKDailyBeacon/# Twitter: https://twitter.com/UTKDailyBeacon Instagram: https://www.instagram.com/utkdailybeacon/?hl=en Check out our website: http://www.utdailybeacon.com/",
                "thumbnailUrl": "https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/e/9e/e9efa63c-fe03-11ea-be0c-63f2aaab7b07/5f6bf41c196c6.preview.jpg?resize=1200%2C675",
                "uploadDate": "2020-09-23T20:18:00-04:00"
            }
        </script></div>
            </div><div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/city_news/what-to-watch-wednesday-s3e4/video_e9efa63c-fe03-11ea-be0c-63f2aaab7b07.html" class="tnt-asset-link">
        

        
            What to Watch Wednesday: S3E4</a></h4></div>
                    
                        <div class="card-lead">
                            <p>In this episode, Jake talks about Break the Silence: The Movie, Akira 4K, Enola Holmes, and &hellip;</p>
                        </div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article></div>
                            </div>
                        </div>
                </div>

                <div class="row">
                <div class="col-sm-6">
                <div class="card-panel panel">
                        <div class="panel-body">
                <div class="hidden-xs">
                <article id="card-showcase-d2250de4-fd13-11ea-b9c7-8b2d5e61e73f" class="clearfix card showcase position-1 even  tnt-section-multimedia">
            <div class="card-container"><div class="card-image ">
                <div class="media-preview-d2250de4-fd13-11ea-b9c7-8b2d5e61e73f media-preview video-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/multimedia/why-is-the-national-anthem-still-an-issue---my-two-cents-e9/video_d2250de4-fd13-11ea-b9c7-8b2d5e61e73f.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Why is the National Anthem Still an Issue? - My Two Cents E9"
                            class="img-responsive lazyload full default"
                            width="1280"
                            height="720"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=200%2C113 200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=300%2C169 300w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=400%2C225 400w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=540%2C304 540w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=750%2C422 750w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=1200%2C675 1200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=1280%2C720 1700w" />
                </a>
                
            </div>
            
        </figure></div>
            </div><div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/multimedia/why-is-the-national-anthem-still-an-issue---my-two-cents-e9/video_d2250de4-fd13-11ea-b9c7-8b2d5e61e73f.html" class="tnt-asset-link">
        

        
            Why is the National Anthem Still an Issue? - My Two Cents E9</a></h4></div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article></div>
                <div class="visible-xs">
                <article id="card-showcase-d2250de4-fd13-11ea-b9c7-8b2d5e61e73f" class="clearfix card showcase position-1 even  tnt-section-multimedia">
            <div class="card-container"><div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/multimedia/why-is-the-national-anthem-still-an-issue---my-two-cents-e9/video_d2250de4-fd13-11ea-b9c7-8b2d5e61e73f.html" class="tnt-asset-link">
        

        
            Why is the National Anthem Still an Issue? - My Two Cents E9</a></h4></div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article></div>
                </div>
                    </div>
                </div>
                
                <div class="col-sm-6">
                <div class="card-panel panel">
                        <div class="panel-body">
                <div class="hidden-xs">
                <article id="card-showcase-db8a89b8-fcf5-11ea-9225-478d27f13c4a" class="clearfix card showcase position-2 odd  tnt-section-campus-news">
            <div class="card-container"><div class="card-image ">
                <div class="media-preview-db8a89b8-fcf5-11ea-9225-478d27f13c4a media-preview video-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/campus_news/utk-free-store---beacon-features/video_db8a89b8-fcf5-11ea-9225-478d27f13c4a.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="UTK Free Store - Beacon Features"
                            class="img-responsive lazyload full default"
                            width="1280"
                            height="720"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/b8/db8a89b8-fcf5-11ea-9225-478d27f13c4a/5f6a2f02c31f6.preview.jpg?resize=200%2C113 200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/b8/db8a89b8-fcf5-11ea-9225-478d27f13c4a/5f6a2f02c31f6.preview.jpg?resize=300%2C169 300w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/b8/db8a89b8-fcf5-11ea-9225-478d27f13c4a/5f6a2f02c31f6.preview.jpg?resize=400%2C225 400w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/b8/db8a89b8-fcf5-11ea-9225-478d27f13c4a/5f6a2f02c31f6.preview.jpg?resize=540%2C304 540w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/b8/db8a89b8-fcf5-11ea-9225-478d27f13c4a/5f6a2f02c31f6.preview.jpg?resize=750%2C422 750w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/b8/db8a89b8-fcf5-11ea-9225-478d27f13c4a/5f6a2f02c31f6.preview.jpg?resize=1200%2C675 1200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/b8/db8a89b8-fcf5-11ea-9225-478d27f13c4a/5f6a2f02c31f6.preview.jpg?resize=1280%2C720 1700w" />
                </a>
                
            </div>
            
        </figure></div>
            </div><div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/campus_news/utk-free-store---beacon-features/video_db8a89b8-fcf5-11ea-9225-478d27f13c4a.html" class="tnt-asset-link">
        

        
            UTK Free Store - Beacon Features</a></h4></div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article></div>
                <div class="visible-xs">
                <article id="card-showcase-db8a89b8-fcf5-11ea-9225-478d27f13c4a" class="clearfix card showcase position-2 odd  tnt-section-campus-news">
            <div class="card-container"><div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/campus_news/utk-free-store---beacon-features/video_db8a89b8-fcf5-11ea-9225-478d27f13c4a.html" class="tnt-asset-link">
        

        
            UTK Free Store - Beacon Features</a></h4></div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article></div>
                </div>
                    </div>
                </div>
                
                    <div class="clearfix hidden-xs"></div>
                
                </div>
                <div class="clearfix hidden-xs"></div>
        </div>
    </section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/city_news\/entertainment","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1211713" class="tncms-block"><section id="block-1211713" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1211713 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/users/admin/calendar/event/">
                
                Submit An Event
                
                    </a>
                
            </h3>
        </div>
    </div></div><article class="card promo media"><div class="media-body"><p>If you have an event you'd like to list on the site, submit it now!</p><a href="/users/admin/calendar/event/">
                <button type="button" class="btn btn-primary  ">Go to form</button>
            </a></div>
</article></section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/city_news\/entertainment","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom2">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom', slot: 2, fold: "below"});</script>

</div>

<div id="blox-ad-position-fixed-big-ad-bottom3">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom', slot: 3, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1211652" class="tncms-block"><section id="block-1211652" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1211652 ">
        <div class="block-title-inner">
            <h3>
                
                Multimedia News
                
            </h3>
        </div>
    </div></div>
    
    <div class="card-img-md card-bg-color card-compact">
        
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1211652-e9efa63c-fe03-11ea-be0c-63f2aaab7b07" class="tnt-asset-type-video clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-city-news">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-e9efa63c-fe03-11ea-be0c-63f2aaab7b07 media-preview video-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/city_news/what-to-watch-wednesday-s3e4/video_e9efa63c-fe03-11ea-be0c-63f2aaab7b07.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="What to Watch Wednesday: S3E4"
                            class="img-responsive lazyload full default"
                            width="1280"
                            height="720"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/e/9e/e9efa63c-fe03-11ea-be0c-63f2aaab7b07/5f6bf41c196c6.preview.jpg?resize=200%2C113 200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/e/9e/e9efa63c-fe03-11ea-be0c-63f2aaab7b07/5f6bf41c196c6.preview.jpg?resize=300%2C169 300w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/e/9e/e9efa63c-fe03-11ea-be0c-63f2aaab7b07/5f6bf41c196c6.preview.jpg?resize=400%2C225 400w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/e/9e/e9efa63c-fe03-11ea-be0c-63f2aaab7b07/5f6bf41c196c6.preview.jpg?resize=540%2C304 540w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/e/9e/e9efa63c-fe03-11ea-be0c-63f2aaab7b07/5f6bf41c196c6.preview.jpg?resize=750%2C422 750w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/e/9e/e9efa63c-fe03-11ea-be0c-63f2aaab7b07/5f6bf41c196c6.preview.jpg?resize=1200%2C675 1200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/e/9e/e9efa63c-fe03-11ea-be0c-63f2aaab7b07/5f6bf41c196c6.preview.jpg?resize=1280%2C720 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/city_news/what-to-watch-wednesday-s3e4/video_e9efa63c-fe03-11ea-be0c-63f2aaab7b07.html" class="tnt-asset-link">
        

        
            What to Watch Wednesday: S3E4</a></h3></div><div class="card-meta">
            <ul class="list-inline"><li class="card-date"><span class="text-muted tnt-update-recent">Updated </span>
        <time datetime="2020-09-23T21:19:25-04:00" class="tnt-date tnt-update-recent asset-date text-muted">20 hrs ago</time>
    </li><li class="card-comment-count"><a href="/city_news/what-to-watch-wednesday-s3e4/video_e9efa63c-fe03-11ea-be0c-63f2aaab7b07.html#comments" class="cm"><span class="fas tnt-comments"></span></a></li></ul>
        </div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">In this episode, Jake talks about Break the Silence: The Movie, Akira 4K, Enola Holmes, and Secret Society of Second-Born Royals. Check out What to Watch Wednesday every week to stay up to date with new movies releasing in theaters near you! </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1211652-d2250de4-fd13-11ea-b9c7-8b2d5e61e73f" class="tnt-asset-type-video clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-multimedia">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-d2250de4-fd13-11ea-b9c7-8b2d5e61e73f media-preview video-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/multimedia/why-is-the-national-anthem-still-an-issue---my-two-cents-e9/video_d2250de4-fd13-11ea-b9c7-8b2d5e61e73f.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Why is the National Anthem Still an Issue? - My Two Cents E9"
                            class="img-responsive lazyload full default"
                            width="1280"
                            height="720"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=200%2C113 200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=300%2C169 300w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=400%2C225 400w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=540%2C304 540w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=750%2C422 750w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=1200%2C675 1200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/assets/v3/editorial/d/22/d2250de4-fd13-11ea-b9c7-8b2d5e61e73f/5f6a61b473fa5.preview.jpg?resize=1280%2C720 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/multimedia/why-is-the-national-anthem-still-an-issue---my-two-cents-e9/video_d2250de4-fd13-11ea-b9c7-8b2d5e61e73f.html" class="tnt-asset-link">
        

        
            Why is the National Anthem Still an Issue? - My Two Cents E9</a></h3></div><div class="card-meta">
            <ul class="list-inline"><li class="card-date"><span class="text-muted tnt-update-recent">Updated </span>
        <time datetime="2020-09-22T16:42:58-04:00" class="tnt-date tnt-update-recent asset-date text-muted">Sep 22, 2020</time>
    </li><li class="card-comment-count"><a href="/multimedia/why-is-the-national-anthem-still-an-issue---my-two-cents-e9/video_d2250de4-fd13-11ea-b9c7-8b2d5e61e73f.html#comments" class="cm"><span class="fas tnt-comments"></span></a></li></ul>
        </div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">OPINION: In this episode, Grant discusses the controversy surrounding the continued protesting of the national anthem in the NFL. </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            </div></section></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"><div id="tncms-block-1278652" class="tncms-block">
        <div id="blox-ad-position-Rail-tall1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"Rail-tall","slot":"1","fold":"","width":"90","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1211610" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1211611" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1211685" class="tncms-block"><section id="block-1211685" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1211685 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-home"  href="/home" >
                    <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/news" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/sports" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-arts-and-culture"  href="/arts_and_culture/" >
                    <span class="nav-label">Arts and Culture</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/opinion" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-photos"  href="/gallery" >
                    <span class="nav-label">Photos</span>
                </a></li><li>
                <a class="nav-link  tnt-section-video-and-audio"  href="/multimedia/" >
                    <span class="nav-label">Video and Audio</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1211686" class="tncms-block"><section id="block-1211686" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1211686 ">
        <div class="block-title-inner">
            <h4>
                
                Submissions
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertise"  href="/site/advertise.html" >
                    <span class="nav-label">Advertise</span>
                </a></li><li>
                <a class="nav-link  tnt-section-email-alerts"  href="/newsletters/" >
                    <span class="nav-label">Email Alerts</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submission-forms"  href="/site/forms" >
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link  tnt-section-events"  href="/events/" >
                    <span class="nav-label">Events</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1211699" class="tncms-block padding-bottom"><section id="block-1211699" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/custom/image/e2e36eaa-d7e0-11e8-8979-3f89c9d00b94.png?resize=200%2C35 200w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/custom/image/e2e36eaa-d7e0-11e8-8979-3f89c9d00b94.png?resize=300%2C53 300w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/custom/image/e2e36eaa-d7e0-11e8-8979-3f89c9d00b94.png?resize=400%2C70 400w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/custom/image/e2e36eaa-d7e0-11e8-8979-3f89c9d00b94.png?resize=540%2C95 540w, https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/content/tncms/custom/image/e2e36eaa-d7e0-11e8-8979-3f89c9d00b94.png 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-1211691" class="tncms-block"><section id="block-1211691" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1211691 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="http://www.utdailybeacon.com/site/contact.html">
                
                Contact Information
                
                    </a>
                
            </h4>
        </div>
    </div></div><address>
    <strong>utdailybeacon.com</strong><br>
    1345 Circle Park, 11 Communications Building<br>
    Knoxville, TN 37996
    <br>
    
        <strong>Phone:</strong> 865-974-5206<br>
        <strong>Email:</strong> <a href="mailto:editorinchief@utdailybeacon.com">editorinchief@utdailybeacon.com</a><br>
    
</address></section></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                


	
<script type="text/javascript" data-id="fdx" data-container="asset-content" data-float="right" data-token="141793" src="//static.flytedesk.com/fdx.js"></script>

            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1211692" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1211692"><div class="col-md-7"><small>&copy; Copyright 2020 <a href="/">University of Tennessee Daily Beacon</a>, 1345 Circle Park, 11 Communications Building Knoxville, TN</small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/utdailybeacon.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/city_news\/entertainment","refresh":false}' style="display:none;"></div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("66f6f9d2-fe95-11ea-b6aa-c765948b3777")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/owl.carousel.66c591eb93f177b0f59892f361c3b1b4.js"></script>
<script>/*<![CDATA[*/ 
                jQuery(document).ready(function($) {
            
                var gallery_ad_66f6f9d2_fe95_11ea_b6aa_c765948b3777_photo_modal = false;
                var gallery_changed_66f6f9d2_fe95_11ea_b6aa_c765948b3777_photo_modal = false;
                var sUrl =  window.location.href,
                        sUuid = sUrl.split("_").pop(),
                        sId = sUuid.substring(0, sUuid.indexOf('.')),
                        aInlineImages = document.querySelectorAll('.inline-image .image, .inline-image .expand');
                     for (i = 0; i < aInlineImages.length; ++i) {
                        var oImage = aInlineImages[i],
                            sInstance = oImage.getAttribute('data-instance'),
                            sTarget = oImage.getAttribute('data-target');
                        if (!oImage.classList.contains("tnt-asset-presentation-infographic")) {
	                        if (sInstance != null && sTarget != null){
	                            if (!sInstance.includes(sId)){
	                                oImage.setAttribute('data-instance', '#gallery-items-' + sId + '-photo-modal');
	                            }
	                            if (!sTarget.includes(sId)){
	                                oImage.setAttribute('data-target', '#photo-carousel-' + sId);
	                            }
	                        }
                        }
                     }
                $('#gallery-items-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal .owl-stage-outer").height( $('#carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        

                        
                            var currItem = $('#gallery-items-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal .photo-container').eq(event.item.index).data('count');
                            if(currItem){
                                $('#carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal .current-count').html(currItem);
                            }
                            $('.modal.in, #carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal .item').removeClass('hover');
                        
                        
                });
                
                var photo_carousel_66f6f9d2_fe95_11ea_b6aa_c765948b3777_photo_modal = $('#gallery-items-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal').data('owlCarousel');
                $('#carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_66f6f9d2_fe95_11ea_b6aa_c765948b3777_photo_modal.prev();
                });
                $('#carousel-66f6f9d2-fe95-11ea-b6aa-c765948b3777-photo-modal .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_66f6f9d2_fe95_11ea_b6aa_c765948b3777_photo_modal.next();
                });
            }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                // open photo modal
                jQuery(document).ready(function($){
                    $('[data-photo-target]').on('click', function(e){
                        e.preventDefault();
                        var item_target = $(this).data('target');
                        // get item index
                        var item_index = $(item_target +' '+$(this).data('photo-target')).parent().index();
                        // get current instance of carousel
                        var carousel_instance = $(this).data('instance');
                        var carousel_instance_data = $(carousel_instance).data('owlCarousel');
                        // fix non explict widths at viewports less than 900.
                        if(carousel_instance_data.width() < 320 & carousel_instance_data.viewport() < 900){
                            carousel_instance_data.onThrottledResize();
                        }
                        // load item from index
                        carousel_instance_data.to(item_index, 100, true);
                        // open modal
                        $(item_target).modal({'show':true});
                        __tnt.trackEvent({'category':'tnt-lightbox','action':'carousel-open', 'label':'article', 'value':'1'});
                        return false;
                    });
                    $('.photo-carousel-caption-toggle').on(__tnt.client.clickEvent, function(e){
                        var item_instance = $(this).data('instance');
                        $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon', $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon') == 'minus-circle' ? 'plus-circle' : 'minus-circle');
                    });
                }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/editorial/resources/scripts/tnt.poll.aa4a56a35da582e986ed8bbce2004ea4.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sticky-kit.136ae7f2f818eb47f6ccd0348c560674.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/utdailybeacon.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.54d9f15b0d238de6bb20ec82ed8307ac.js"></script>
<script>/*<![CDATA[*/ (function() {
                    window.addEventListener('load', function() {
                        __tnt.regions.stickySide.init(document.getElementById('sticky-right-rail'), document.getElementById('sticky-right-rail-spacer'), 'siderail', '.row');
                    });
                })(); /*]]>*/</script></body>
</html>